features

EZP2010 high-speed programmer manual

features

Product picture:

Field of application:

This programmer can read and write the bios chips of DVD,TV,PC,harddisk,etc.

Features:

1. USB 2.0 interface, the speed is 12Mbps.

2. The speed of reading and writing is very fast.

3. Auto detect chip modles.

4. Auto select power votage.

6. Auto off-line chip copy.

7. Software and firmware update.

8. Surpport 25 FLASH, 24 EEPROM, 25 EEPROM, 93 EEPROM,etc.

9. Small shape.

10.Windows 2000, Windows XP, Windows Vista, Windows 7.

List:

1. Programmer 1

2. Usb cable 1

3. CD 1

4. Manual(a file on CD) 1

5. 5V power for off-line chip copy 1

6. Simple socket for SMD chips 2

Copyright 2010-2015 elecmicro reserve all rights!


chip list

chip list

This programmer supports all the 24, 25, 93 series memory chips!

********************25 SPI FLASH*******************************************************************

AMIC: A25L05P, A25L512, A25L010, A25L10P, A25L020, A25L20P, A25L040, A25L40P, A25L080, A25L80P, A25L016, A25L16P, A25L032
ATMEL: AT25F512, AT25F512A, AT25F512B, AT25F1024, AT25F1024A, AT25FS010, AT25DF021, AT25F2048, AT25DF041A, AT25F4096, AT25FS040, AT26F004, AT26DF081A, AT25DF161, AT26DF161, AT26DF161A, AT25DF321, AT25DF321A, AT26DF321, AT25DF641
EON: EN25F05, EN25LF05, EN25P05, EN25D10, EN25F10, EN25LF10, EN25P10, EN25D20, EN25F20, EN25LF20, EN25D40, EN25F40, EN25LF40, EN25D80, EN25F80, EN25Q80, EN25T80, EN25B16, EN25B16T, EN25D16, EN25F16, EN25Q16, EN25T16, EN25B32, EN25B32T, EN25F32, EN25P32, EN25Q32, EN25B64, EN25B64T, EN25F64, EN25P64, EN25Q64, EN25F128, EN25Q128
ES: ES25P10, ES25P20, ES25M40, ES25M40A, ES25P40, ES25M80, ES25M80A, ES25P80, ES25M16, ES25M16A, ES25P16, ES25P32
ESMT: F25L004A, F25L04UA, F25L008A, F25L08PA, F25L016A, F25L16PA, F25L32PA, F25L32QA
MXIC: MX25L512, MX25V512, MX25L1005, MX25L2005, MX25L4005A, MX25V4005, MX25L8005, MX25V8005, MX25L1605D, MX25L1635D, MX25L3205D, MX25L3225D, MX25L3235D, MX25L3237D, MX25L6405D, MX25L12805D
NEXFLASH: NX25P10, NX25P20, NX25P40, NX25P80, NX25P16, NX25P32
PMC: PM25LV512A, PM25LV010A, PM25LV020, PM25LV040, PM25LV080B, PM25LV016B
SAIFUN: SA25F005, SA25F010, SA25F020, SA25F040, SA25F080, SA25F160, SA25F320
SPANSION: S25FL004A, S25FL008A, S25FL016A, S25FL032A, S25FL064A
SST: SST25VF512, SST25VF512A, SST25VF010, SST25VF010A, SST25VF020, SST25VF020A, SST25VF040, SST25VF040A, SST25VF040B, SST25VF080B, SST25VF016B, SST25VF032B, SST25VF064C
ST: M25P05A, M25P10A, M25PE10, M25P20, M25PE20, M25P40, M25PE40, M25P80, M25PE80, M25PX80, M25P16, M25PE16, M25PX16, M25P32, M25PX32, M25P64, M25PX64, M25P128
WINBOND: W25P10, W25X10, W25X10A, W25X10AL, W25X10L, W25P20, W25X20, W25X20A, W25X20AL, W25X20L, W25P40, W25X40, W25X40A, W25X40AL, W25X40L, W25P80, W25X80, W25X80A, W25X80AL, W25X80L, W25P16, W25X16, W25P32, W25X32, W25X64

********************24 EEPROM*******************************************************************

ATMEL: AT24C01, AT24C01A, AT24C01B, AT24C02, AT24C02A, AT24C02B, AT24C04, AT24C04A, AT24C04B, AT24C08, AT24C08A, AT24C08B, AT24C16, AT24C16A, AT24C16B, AT24C32, AT24C32A, AT24C32B, AT24C64, AT24C64A, AT24C64B, AT24C128, AT24C128A, AT24C128B, AT24C256, AT24C256A, AT24C256B, AT24C512, AT24C512A, AT24C512B, AT24C1024, AT24C1024A, AT24C1024B

CATALYST: CAT24C01, CAT24WC01, CAT24C02, CAT24WC02, CAT24C04, CAT24WC04, CAT24C08, CAT24WC08, CAT24C16, CAT24WC16, CAT24C32, CAT24WC32, CAT24C64, CAT24WC64, CAT24C128, CAT24WC128, CAT24C256, CAT24WC256, CAT24C512, CAT24WC512, CAT24C1024, CAT24WC1024

COMMON: 24C00 3V, 24C00 5V, 24C01 3V, 24C01 5V, 24C02 3V, 24C02 5V, 24C04 3V, 24C04 5V, 24C08 3V, 24C08 5V, 24C16 3V, 24C16 5V, 24C32 3V, 24C32 5V, 24C64 3V, 24C64 5V, 24C128 3V, 24C128 5V, 24C256 3V, 24C256 5V, 24C512 3V, 24C512 5V, 24C1024 3V, 24C1024 5V

FAIRCHILD: FM24C01L, FM24C02L, FM24C03L, FM24C04L, FM24C05L, FM24C08L, FM24C09L, FM24C16L, FM24C17L, FM24C32L, FM24C64L, FM24C128L, FM24C256L, FM24C512L, FM24C1024L

HOLTEK: HT24C01, HT24LC01, HT24C02, HT24LC02, HT24C04, HT24LC04, HT24C08, HT24LC08, HT24C16, HT24LC16, HT24C32, HT24LC32, HT24C64, HT24LC64, HT24C128, HT24LC128, HT24C256, HT24LC256, HT24C512, HT24C1024

ISSI: IS24C01, IS24C02, IS24C04, IS24C08, IS24C16, IS24C32, IS24C64, IS24C128, IS24C256, IS24C512, IS24C1024

MICROCHIP: 24AA00, 24C00, 24LC00, 24AA01, 24AA014, 24C01C, 24LC014, 24LC01B, 24AA02, 24LC02B, 24AA024, 24AA025, 24AA04, 24C02C, 24LC024, 24LC025, 24LC04B, 24AA08, 24LC08B, 24AA16, 24LC16B, 24AA32, 24LC32, 24AA64, 24FC64, 24LC64, 24AA128, 24FC128, 24LC128, 24AA256, 24FC256, 24LC256, 24AA512, 24FC512, 24LC512, 24AA1024

NSC: NSC24C02, NSC24C02L, NSC24C64

RAMTRON: FM24C04A, FM24CL04, FM24C16A, FM24CL16, FM24C64, FM24CL64, FM24C256, FM24CL256, FM24C512

ROHM: BR24C01, BR24L01, BR24C02, BR24L02, BR24C04, BR24L04, BR24C08, BR24L08, BR24C16, BR24L16, BR24C32, BR24L32, BR24C64, BR24L64

ST: ST24C01, ST24C02, ST24C04, ST24C08, ST24C16, ST24C32, ST24C64

XICOR: X24C01, X24C02, X24C04, X24C08, X24C16

********************93 EEPROM*******************************************************************

AKM: AK93C45AV, AK93C55AV, AK93C65AV, AK93C75AV

ATC: ATC93C46, ATC93LC46(16bit), ATC93LC46(16bit)-SOP8, ATC93LC46(8bit),
ATC93LC46(8bit)-SOP8, ATC93C56, ATC93LC56(16bit), ATC93LC56(16bit)-SOP8,
ATC93LC56(8bit), ATC93LC56(8bit)-SOP8, ATC93C66, ATC93LC66(16bit),
ATC93LC66(16bit)-SOP8, ATC93LC66(8bit), ATC93LC66(8bit)-SOP8

ATMEL: AT93C46(16bit), AT93C46(16bit)-SOP8, AT93C46(8bit), AT93C46(8bit)-SOP8,
AT93C46A, AT93C56(16bit), AT93C56(16bit)-SOP8, AT93C56(8bit),
AT93C56(8bit)-SOP8, AT93C57(16bit), AT93C57(16bit)-SOP8, AT93C57(8bit),
AT93C57(8bit)-SOP8, AT93C66(16bit), AT93C66(16bit)-SOP8, AT93C66(8bit),
AT93C66(8bit)-SOP8, AT93C86(16bit), AT93C86(16bit)-SOP8, AT93C86(8bit),
AT93C86(8bit)-SOP8

CATALYST: CAT93C46(16bit), CAT93C46(8bit), CAT93C46A, CAT93C46I, CAT93C56(16bit),
CAT93C56(8bit), CAT93C56A, CAT93C57(16bit), CAT93C57(16bit)-SOP8,
CAT93C66(16bit), CAT93C66(8bit), CAT93C66A, CAT93C86(16bit),
CAT93C86(8bit)

COMMON: 93C46(16bit), 93C46(8bit), 93C56(16bit), 93C56(8bit), 93C66(16bit), 93C66(8bit), 93C86(16bit), 93C86(8bit)

EXEL: XL93C06, XL93C46, XL93CS46, XL93LC46, XL93C56, XL93LC56, XL93C66, XL93LC66

FAIRCHILD:
FM93C06AM8(16bit), FM93C06AM8(8bit), FM93C06M8, FM93C06N,
FM93C46AM8(16bit), FM93C46AM8(8bit), FM93C46AN(16bit), FM93C46AN(8bit),
FM93CS46(16bit), FM93C56AN(16bit), FM93C56AN(8bit), FM93CS56(16bit),
FM93C66AM8(16bit), FM93C66AM8(8bit), FM93C66AN(16bit), FM93C66AN(8bit),
FM93C66B, FM93C66M8(16bit), FM93C66MT8(16bit), FM93C66N(16bit), FM93CS66(16bit),
FM93C86AM8(16bit), FM93C86AM8(8bit), FM93C86AN(16bit),
FM93C86AN(8bit)

HOLTEK: HT93LC46A(16bit), HT93LC46A(8bit), HT93LC56A(16bit), HT93LC56A(8bit), HT93LC66A(16bit), HT93LC66A(8bit)

ICT: ICT93C46(16bit), ICT93C46(8bit), ICT93C56(16bit), ICT93C56(8bit), ICT93C66(16bit), ICT93C66(8bit)

ISSI: IS93C46(16bit), IS93C56(16bit), IS93C66(16bit)

MICROCHIP: 93C06(16bit), 93C06(16bit)-SOP8, 93AA46(16bit), 93AA46(8bit), 93AA46(8bit)-SOP8, 93C46(16bit), 93C46(16bit)-SOP8, 93C46A, 93C46B, 93LC46(16bit), 93LC46(16bit)-SOP8, 93LC46(8bit), 93LC46(8bit)-SOP8, 93LC46A, 93LC46B, 93LC46B-SOP8, 93AA56(16bit), 93AA56(8bit), 93AA56(8bit)-SOP8, 93C56(16bit), 93C56(16bit)-SOP8, 93C56(8bit), 93C56(8bit)-SOP8, 93C56A, 93C56A-SOP8, 93C56B, 93C56B-SOP8, 93LC56(16bit), 93LC56(16bit)-SOP8, 93LC56(8bit), 93LC56(8bit)-SOP8, 93LC56A, 93LC56B, 93LC56B-SOP8, 93AA66(16bit), 93AA66(8bit), 93AA66(8bit)-SOP8, 93C66(16bit), 93C66(16bit)-SOP8, 93C66(8bit), 93C66(8bit)-SOP8, 93C66A, 93C66A-SOP8, 93C66B, 93C66B-SOP8, 93LC66(16bit), 93LC66(16bit)-SOP8, 93LC66(8bit), 93LC66(8bit)-SOP8, 93LC66A, 93LC66B, 93LC66B-SOP8, 93AA76(16bit), 93AA76(8bit), 93C76(16bit), 93C76(8bit), 93LC76(16bit), 93LC76(8bit), 93LC76A, 93LC76B, 93AA86(16bit), 93AA86(8bit), 93C86(16bit), 93C86(8bit), 93LC86(16bit), 93LC86(8bit), 93LC86A, 93LC86B
NSC: NSC93C06, NSC93C06-SOP8, NSC93CS06, NSC93C46, NSC93CS46, NSC93C56, NSC93CS56, NSC93S56, NSC93C66, NSC93CS66, NSC93C86

ROHM: BR93LC46, BR93LC46RF, BR93LC56, BR93LC56RF, BR93LC66, BR93LC66RF

ST: ST93C06, M93S46, M93S46-SOP8, M93S46-T8, M93S46R, M93S46R-SOP8, M93S46W, M93S46W-SOP8, ST93C46, M93S56, M93S56-SOP8, M93S56R, M93S56R-SOP8, M93S56W, M93S56W-SOP8, ST93C56, M93S66, M93S66-SOP8, M93S66R, M93S66R-SOP8, M93S66W, M93S66W-SOP8, ST93C66

********************25 EEPROM*******************************************************************

ATMEL: AT25010, AT25020, AT25040, AT25080, AT25160, AT25320, AT25640, AT25128, AT25256, AT25512

CATALYST: CAT25C01, CAT25C01P, CAT25C01S, CAT25C01U, CAT25C02P, CAT25C02S, CAT25C02U, CAT25C03P, CAT25C03S, CAT25C03U, CAT25C04P, CAT25C04S, CAT25C04U, CAT25C05P, CAT25C05S, CAT25C05U, CAT25C08P, CAT25C08S, CAT25C08U, CAT25C09P, CAT25C09S, CAT25C09U, CAT25C16P, CAT25C16S, CAT25C16U, CAT25C17P, CAT25C17S, CAT25C17U, CAT25C32P, CAT25C32S, CAT25C33P, CAT25C33S, CAT25C64P, CAT25C64S, CAT25C65P, CAT25C65S, CAT25C128P, CAT25C128S, CAT25C256P, CAT25C256S

COMMON: 25010, 25020, 25040, 25080, 25160, 25320, 25640, 25128, 25256, 25512

MICROCHIP: 25AA040, 25C040, 25LC040, 25AA080, 25C080, 25LC080, 25AA160, 25C160, 25LC160, 25AA320, 25C320, 25LC320, 25AA640, 25C640, 25LC640

RAMTRON: FM25C160, FM25640, FM25CL64

ST: ST25C01, ST25W01, ST25C02, ST25W02, ST25C04, ST25W04, ST25C08, ST25W08, ST25C16, ST25W16

TI: TI2532, TI2532A, TI2564

XICOR: XC25010, XC25020, XC25040, XC25080, XC25160, XC25320, XC25640, XC25128, XC25256, XC25512


software setup

software setup

No need to install, please run the *.exe programm.


driver setup

driver setup

There are tow usb device driver files: EZP2010.inf and EZP2010.sys.

The step of usb driver setup is same as other usb devices.


system requirements

system requirements

System software requirements:

Windows 2000,Windows XP,Windows Vista,Windows 7.

System hardware requirements:

USB1.0 interface.
CD-ROM.
64MB RAM.
10MB harddisk space.


select chip

select chip

User can select chip modle from "Type", "Manu" and "Chip" combox.

User can click "Search" to select chip modle too.


software UI

software UI

1. Open File: Load data to buffer from file.

2. Save File: Save data to file from buffer.

3. Buffer Fill: Fill buffer to specified datas.

4. Byte Swap: Swap the bytes in the buffer.

5. Auto: Erase, write and verify.

6. Erase: Erase chip.

7. Write: Write data to chip from buffer.

8. Read: Read data to buffer from chip.

9. Verify: Compare the data in chip to the data in buffer.

10.Detect: Detect chip modle.

11.Version: Read firmware version.

12.Update: Update firmware.

13.Help: Open the user manual.

14.About: View the version information of software.


edit

edit

User can change data in buffer.


search chip

search chip

Click "Search", then pop the above dialog, enter the keyword, the matched chips will be listed in the listbox.


detect chip

detect chip

Click "Detect", the software will pop a messagebox to show chip name.

The programmer only can detect 25 series spi flash.


open file

open file

Load data to buffer from a bin file or a hex file.


save file

save file

Save data to a bin file from buffer.


firmware update

firmware update

User can click "Update" botton to update firmware.

Select the correct update file (*.ezp), and the updating operation will complete in several seconds.

If the operation is successful, the software will pop the messagebox as below:

If the operation is unsuccessful, the software will pop the messagebox as below:

First remove the programmer from PC, then click "OK", and link the programmer to PC again.


off-line copy

off-line copy

The programmer can copy one chip to another chip.

When the programmer detects two chips on the socket, it will automatically start copying operation.

1. When off-line copying, the programmer can link to 5V power as well as link to PC.

2. The programmer can copy data to a 24 eeprom from another 24 eeprom.

3. The programmer can copy data to a 25 flash from another 25 flash.

4. The capacity of destination chip must be equal to source chip.


erase chip

erase chip

One 25 flash must be erased before writing.

No need to erase one 24 eeprom before writting.

No need to erase one 93 eeprom before writting.


read chip

read chip

Read data to buffer from chip.


write chip

write chip

Write data to chip from buffer.


verify chip

verify chip

Compare the data in chip to the data in buffer.

It's necessary to execute the verify command after writting.


auto

auto

Erase, write and verify.


FAQ

FAQ

1. Verify error.

(1)User must select a correct chip modle before writting.

(2)User must erase chip before writting if che chip is a 25 flash.

(3)User must select a correct memory unit width if che chip is a 93 eeprom.

(4)The chip maybe bad.

2. Chip position when reading and writting.

(1)If the programmer is linked to PC, the chip must be placed in the socket as below:

3. Automatically detect chip modle unsuccessful.

See the section "detect chip" in this document.

4. The simple SMD socket.

The simple SMD socket has tow chip positions.

User can place SMD chip on any one of the tow position.

5. Read and write chips on the mainboard (ISP).

User can link programmer to mainboard to read and write bios chips.

User can link GND, CS, MISO, MOSI, CLK signals to mainboard.