产品特性

EZP2010高速编程器用户手册

产品特性

产品图片:

应用领域:

1. 家电维修: 适合于家电维修行业刷写彩电、DVD、电脑主板、硬盘上的存储芯片。

2. 产品研发: 公司产品研发过程中烧写测试芯片。

3. 工厂量产: 全自动脱机拷贝功能特别适合于工厂批量烧录存储器芯片。

产品特点:

1. USB 2.0接口，速度高达12Mbps。

2. 读写速度超快，读EN25T80只要3秒，写EN25T80只要9秒，是目前市面上速度最快的BIOS芯片编程器。

3. 自动识别芯片型号。

4. 自动检测芯片是否放好。

5. 自动选择芯片供电电压。

6. 自动脱机拷贝。

7. 支持PC软件和编程器固件升级。

8. 全面支持25 FLASH、24 EEPROM、25 EEPROM、93 EEPROM等系列的存储芯片。

9. 外形小巧，携带方便，和普通名片差不多大。

10.支持Windows 2000、Windows XP、Windows Vista、Windows 7。

销售清单:

1. 编程器主机 1台

2. 高速屏蔽USB通讯电缆 1根

3. 产品光盘 1张

4. 产品说明书（光盘文件） 1份

5. 脱机拷贝稳压电源 1个

6. 简易贴片转接座 2个

Copyright 2010-2015 米克电子 版权所有 保留所有权利！


支持芯片

支持芯片

支持目前市场上几乎所有厂商的24，25，93系列芯片！

********************25 SPI FLASH*******************************************************************

AMIC: A25L05P, A25L512, A25L010, A25L10P, A25L020, A25L20P, A25L040, A25L40P, A25L080, A25L80P, A25L016, A25L16P, A25L032
ATMEL: AT25F512, AT25F512A, AT25F512B, AT25F1024, AT25F1024A, AT25FS010, AT25DF021, AT25F2048, AT25DF041A, AT25F4096, AT25FS040, AT26F004, AT26DF081A, AT25DF161, AT26DF161, AT26DF161A, AT25DF321, AT25DF321A, AT26DF321, AT25DF641
EON: EN25F05, EN25LF05, EN25P05, EN25D10, EN25F10, EN25LF10, EN25P10, EN25D20, EN25F20, EN25LF20, EN25D40, EN25F40, EN25LF40, EN25D80, EN25F80, EN25Q80, EN25T80, EN25B16, EN25B16T, EN25D16, EN25F16, EN25Q16, EN25T16, EN25B32, EN25B32T, EN25F32, EN25P32, EN25Q32, EN25B64, EN25B64T, EN25F64, EN25P64, EN25Q64, EN25F128, EN25Q128
ES: ES25P10, ES25P20, ES25M40, ES25M40A, ES25P40, ES25M80, ES25M80A, ES25P80, ES25M16, ES25M16A, ES25P16, ES25P32
ESMT: F25L004A, F25L04UA, F25L008A, F25L08PA, F25L016A, F25L16PA, F25L32PA, F25L32QA
MXIC: MX25L512, MX25V512, MX25L1005, MX25L2005, MX25L4005A, MX25V4005, MX25L8005, MX25V8005, MX25L1605D, MX25L1635D, MX25L3205D, MX25L3225D, MX25L3235D, MX25L3237D, MX25L6405D, MX25L12805D
NEXFLASH: NX25P10, NX25P20, NX25P40, NX25P80, NX25P16, NX25P32
PMC: PM25LV512A, PM25LV010A, PM25LV020, PM25LV040, PM25LV080B, PM25LV016B
SAIFUN: SA25F005, SA25F010, SA25F020, SA25F040, SA25F080, SA25F160, SA25F320
SPANSION: S25FL004A, S25FL008A, S25FL016A, S25FL032A, S25FL064A
SST: SST25VF512, SST25VF512A, SST25VF010, SST25VF010A, SST25VF020, SST25VF020A, SST25VF040, SST25VF040A, SST25VF040B, SST25VF080B, SST25VF016B, SST25VF032B, SST25VF064C
ST: M25P05A, M25P10A, M25PE10, M25P20, M25PE20, M25P40, M25PE40, M25P80, M25PE80, M25PX80, M25P16, M25PE16, M25PX16, M25P32, M25PX32, M25P64, M25PX64, M25P128
WINBOND: W25P10, W25X10, W25X10A, W25X10AL, W25X10L, W25P20, W25X20, W25X20A, W25X20AL, W25X20L, W25P40, W25X40, W25X40A, W25X40AL, W25X40L, W25P80, W25X80, W25X80A, W25X80AL, W25X80L, W25P16, W25X16, W25P32, W25X32, W25X64

********************24 EEPROM*******************************************************************

ATMEL: AT24C01, AT24C01A, AT24C01B, AT24C02, AT24C02A, AT24C02B, AT24C04, AT24C04A, AT24C04B, AT24C08, AT24C08A, AT24C08B, AT24C16, AT24C16A, AT24C16B, AT24C32, AT24C32A, AT24C32B, AT24C64, AT24C64A, AT24C64B, AT24C128, AT24C128A, AT24C128B, AT24C256, AT24C256A, AT24C256B, AT24C512, AT24C512A, AT24C512B, AT24C1024, AT24C1024A, AT24C1024B

CATALYST: CAT24C01, CAT24WC01, CAT24C02, CAT24WC02, CAT24C04, CAT24WC04, CAT24C08, CAT24WC08, CAT24C16, CAT24WC16, CAT24C32, CAT24WC32, CAT24C64, CAT24WC64, CAT24C128, CAT24WC128, CAT24C256, CAT24WC256, CAT24C512, CAT24WC512, CAT24C1024, CAT24WC1024

COMMON: 24C00 3V, 24C00 5V, 24C01 3V, 24C01 5V, 24C02 3V, 24C02 5V, 24C04 3V, 24C04 5V, 24C08 3V, 24C08 5V, 24C16 3V, 24C16 5V, 24C32 3V, 24C32 5V, 24C64 3V, 24C64 5V, 24C128 3V, 24C128 5V, 24C256 3V, 24C256 5V, 24C512 3V, 24C512 5V, 24C1024 3V, 24C1024 5V

FAIRCHILD: FM24C01L, FM24C02L, FM24C03L, FM24C04L, FM24C05L, FM24C08L, FM24C09L, FM24C16L, FM24C17L, FM24C32L, FM24C64L, FM24C128L, FM24C256L, FM24C512L, FM24C1024L

HOLTEK: HT24C01, HT24LC01, HT24C02, HT24LC02, HT24C04, HT24LC04, HT24C08, HT24LC08, HT24C16, HT24LC16, HT24C32, HT24LC32, HT24C64, HT24LC64, HT24C128, HT24LC128, HT24C256, HT24LC256, HT24C512, HT24C1024

ISSI: IS24C01, IS24C02, IS24C04, IS24C08, IS24C16, IS24C32, IS24C64, IS24C128, IS24C256, IS24C512, IS24C1024

MICROCHIP: 24AA00, 24C00, 24LC00, 24AA01, 24AA014, 24C01C, 24LC014, 24LC01B, 24AA02, 24LC02B, 24AA024, 24AA025, 24AA04, 24C02C, 24LC024, 24LC025, 24LC04B, 24AA08, 24LC08B, 24AA16, 24LC16B, 24AA32, 24LC32, 24AA64, 24FC64, 24LC64, 24AA128, 24FC128, 24LC128, 24AA256, 24FC256, 24LC256, 24AA512, 24FC512, 24LC512, 24AA1024

NSC: NSC24C02, NSC24C02L, NSC24C64

RAMTRON: FM24C04A, FM24CL04, FM24C16A, FM24CL16, FM24C64, FM24CL64, FM24C256, FM24CL256, FM24C512

ROHM: BR24C01, BR24L01, BR24C02, BR24L02, BR24C04, BR24L04, BR24C08, BR24L08, BR24C16, BR24L16, BR24C32, BR24L32, BR24C64, BR24L64

ST: ST24C01, ST24C02, ST24C04, ST24C08, ST24C16, ST24C32, ST24C64

XICOR: X24C01, X24C02, X24C04, X24C08, X24C16

********************93 EEPROM*******************************************************************

AKM: AK93C45AV, AK93C55AV, AK93C65AV, AK93C75AV

ATC:
ATC93C46, ATC93LC46(16bit),
ATC93LC46(16bit)-SOP8, ATC93LC46(8bit), ATC93LC46(8bit)-SOP8, ATC93C56,
ATC93LC56(16bit), ATC93LC56(16bit)-SOP8, ATC93LC56(8bit), ATC93LC56(8bit)-SOP8,
ATC93C66, ATC93LC66(16bit), ATC93LC66(16bit)-SOP8, ATC93LC66(8bit),
ATC93LC66(8bit)-SOP8

ATMEL: AT93C46(16bit),
AT93C46(16bit)-SOP8, AT93C46(8bit), AT93C46(8bit)-SOP8, AT93C46A,
AT93C56(16bit), AT93C56(16bit)-SOP8, AT93C56(8bit), AT93C56(8bit)-SOP8,
AT93C57(16bit), AT93C57(16bit)-SOP8, AT93C57(8bit), AT93C57(8bit)-SOP8,
AT93C66(16bit), AT93C66(16bit)-SOP8, AT93C66(8bit), AT93C66(8bit)-SOP8,
AT93C86(16bit), AT93C86(16bit)-SOP8, AT93C86(8bit),
AT93C86(8bit)-SOP8

CATALYST: CAT93C46(16bit),
CAT93C46(8bit), CAT93C46A, CAT93C46I, CAT93C56(16bit), CAT93C56(8bit),
CAT93C56A, CAT93C57(16bit), CAT93C57(16bit)-SOP8, CAT93C66(16bit),
CAT93C66(8bit), CAT93C66A, CAT93C86(16bit), CAT93C86(8bit)

COMMON: 93C46(16bit), 93C46(8bit), 93C56(16bit), 93C56(8bit), 93C66(16bit), 93C66(8bit), 93C86(16bit), 93C86(8bit)

EXEL: XL93C06, XL93C46, XL93CS46, XL93LC46, XL93C56, XL93LC56, XL93C66, XL93LC66

FAIRCHILD: FM93C06AM8(16bit),
FM93C06AM8(8bit), FM93C06M8, FM93C06N, FM93C46AM8(16bit), FM93C46AM8(8bit),
FM93C46AN(16bit), FM93C46AN(8bit), FM93CS46(16bit), FM93C56AN(16bit),
FM93C56AN(8bit), FM93CS56(16bit), FM93C66AM8(16bit), FM93C66AM8(8bit),
FM93C66AN(16bit), FM93C66AN(8bit), FM93C66B, FM93C66M8(16bit),
FM93C66MT8(16bit), FM93C66N(16bit), FM93CS66(16bit), FM93C86AM8(16bit),
FM93C86AM8(8bit), FM93C86AN(16bit), FM93C86AN(8bit)

HOLTEK: HT93LC46A(16bit),
HT93LC46A(8bit), HT93LC56A(16bit), HT93LC56A(8bit), HT93LC66A(16bit),
HT93LC66A(8bit)

ICT: ICT93C46(16bit), ICT93C46(8bit), ICT93C56(16bit), ICT93C56(8bit), ICT93C66(16bit), ICT93C66(8bit)

ISSI: IS93C46(16bit), IS93C56(16bit), IS93C66(16bit)

MICROCHIP: 93C06(16bit), 93C06(16bit)-SOP8, 93AA46(16bit), 93AA46(8bit), 93AA46(8bit)-SOP8, 93C46(16bit), 93C46(16bit)-SOP8, 93C46A, 93C46B, 93LC46(16bit), 93LC46(16bit)-SOP8, 93LC46(8bit), 93LC46(8bit)-SOP8, 93LC46A, 93LC46B, 93LC46B-SOP8, 93AA56(16bit), 93AA56(8bit), 93AA56(8bit)-SOP8, 93C56(16bit), 93C56(16bit)-SOP8, 93C56(8bit), 93C56(8bit)-SOP8, 93C56A, 93C56A-SOP8, 93C56B, 93C56B-SOP8, 93LC56(16bit), 93LC56(16bit)-SOP8, 93LC56(8bit), 93LC56(8bit)-SOP8, 93LC56A, 93LC56B, 93LC56B-SOP8, 93AA66(16bit), 93AA66(8bit), 93AA66(8bit)-SOP8, 93C66(16bit), 93C66(16bit)-SOP8, 93C66(8bit), 93C66(8bit)-SOP8, 93C66A, 93C66A-SOP8, 93C66B, 93C66B-SOP8, 93LC66(16bit), 93LC66(16bit)-SOP8, 93LC66(8bit), 93LC66(8bit)-SOP8, 93LC66A, 93LC66B, 93LC66B-SOP8, 93AA76(16bit), 93AA76(8bit), 93C76(16bit), 93C76(8bit), 93LC76(16bit), 93LC76(8bit), 93LC76A, 93LC76B, 93AA86(16bit), 93AA86(8bit), 93C86(16bit), 93C86(8bit), 93LC86(16bit), 93LC86(8bit), 93LC86A, 93LC86B
NSC: NSC93C06, NSC93C06-SOP8, NSC93CS06, NSC93C46, NSC93CS46, NSC93C56, NSC93CS56, NSC93S56, NSC93C66, NSC93CS66, NSC93C86

ROHM: BR93LC46, BR93LC46RF, BR93LC56, BR93LC56RF, BR93LC66, BR93LC66RF

ST: ST93C06, M93S46, M93S46-SOP8, M93S46-T8, M93S46R, M93S46R-SOP8, M93S46W, M93S46W-SOP8, ST93C46, M93S56, M93S56-SOP8, M93S56R, M93S56R-SOP8, M93S56W, M93S56W-SOP8, ST93C56, M93S66, M93S66-SOP8, M93S66R, M93S66R-SOP8, M93S66W, M93S66W-SOP8, ST93C66

********************25 EEPROM*******************************************************************

ATMEL: AT25010, AT25020, AT25040, AT25080, AT25160, AT25320, AT25640, AT25128, AT25256, AT25512

CATALYST: CAT25C01, CAT25C01P, CAT25C01S, CAT25C01U, CAT25C02P, CAT25C02S, CAT25C02U, CAT25C03P, CAT25C03S, CAT25C03U, CAT25C04P, CAT25C04S, CAT25C04U, CAT25C05P, CAT25C05S, CAT25C05U, CAT25C08P, CAT25C08S, CAT25C08U, CAT25C09P, CAT25C09S, CAT25C09U, CAT25C16P, CAT25C16S, CAT25C16U, CAT25C17P, CAT25C17S, CAT25C17U, CAT25C32P, CAT25C32S, CAT25C33P, CAT25C33S, CAT25C64P, CAT25C64S, CAT25C65P, CAT25C65S, CAT25C128P, CAT25C128S, CAT25C256P, CAT25C256S

COMMON: 25010, 25020, 25040, 25080, 25160, 25320, 25640, 25128, 25256, 25512

MICROCHIP: 25AA040, 25C040, 25LC040, 25AA080, 25C080, 25LC080, 25AA160, 25C160, 25LC160, 25AA320, 25C320, 25LC320, 25AA640, 25C640, 25LC640

RAMTRON: FM25C160, FM25640, FM25CL64

ST: ST25C01, ST25W01, ST25C02, ST25W02, ST25C04, ST25W04, ST25C08, ST25W08, ST25C16, ST25W16

TI: TI2532, TI2532A, TI2564

XICOR: XC25010, XC25020, XC25040, XC25080, XC25160, XC25320, XC25640, XC25128, XC25256, XC25512


软件安装

软件安装

本软件纯绿色，免安装。

软件压缩包解压后双击软件所在目录中的*.exe程序即可运行编程器软件。


驱动安装

驱动安装

1. 首次连接到电脑会弹出下面的“找到新的硬件向导”对话框，选“否，暂时不”，点“下一步”。

2. 选“从列表或指定位置安装(高级)”，点“下一步”。

3. 选“不要搜索。我要自己选择要安装的驱动程序。”，点“下一步”。

4. 点“从磁盘安装”。

6. 点“浏览”。

7. 从“查找文件”对话框中选择EZP2010.inf文件，点“打开”。

8. 点“下一步”。

9. 安装成功后出现下面的对话框。


运行环境

运行环境

操作系统:

Windows 2000、Windows XP、Windows Vista、Windows 7。

硬件最小配置:

IBM-PC 586或奔腾兼容机，台式或手提电脑.

USB1.0标准的通用串行总线接口。
CD-ROM光驱。
64M的RAM。
硬盘至少10M剩余空间。


选择芯片

选择芯片

用户可以从“类型”、“厂商”、“器件”下拉列表框中选择正确的芯片型号。

用户也可以点“芯片查找”按钮，在芯片查找对话框中选择正确的芯片型号。


软件界面

软件界面

1. 打开: 从文件加载数据到缓冲区。

2. 保存: 将缓冲区中数据保存到文件。

3. 填充: 将缓冲区填充指定的数据。

4. 交换: 将缓冲区中相邻的两个字节数据交换位置。

5. 自动: 自动完成擦除芯片、写芯片、校验芯片操作。

6. 擦除: 擦除芯片。

7. 编程: 将缓冲区中的数据写入到芯片。

8. 读出: 将芯片内的数据读到缓冲区。

9. 校验: 比较芯片和缓冲区中的数据是否相同。

10.检测: 自动检测芯片型号。

11.版本: 查看编程器固件的版本号。

12.升级: 升级编程器固件。

13.帮助: 打开帮助文件。

14.关于: 显示编程器软件版本信息。


编辑缓冲区

编辑缓冲区

1. 缓冲区填充:

该命令将缓冲区中指定地址但愿填充成特定数据。

“地址”表示要填充缓冲区的首地址。

“长度”表示要填充的字节数。

“数据”表示要填充的数据。

以上数据均为16进制表示方式。

2. 高低字节交换:

将缓冲区中相邻的两个字节互相交换。

3. 直接修改缓冲区内容:

可以在缓冲区内容列表中直接修改缓冲区的内容。


查找芯片

查找芯片

用户点“芯片查找”按钮后弹出上面的查找对话框。

用户可以输入查找的关键字进行模糊查询，查询到的结果会显示在列表中。


自动检测芯片型号

自动检测芯片型号

点工具条或菜单中的“检测”按钮后，编程器会自动识别出编程器上所放芯片的型号。

使用本命令请注意以下几点：

1. 由于技术上的原因，自动检测芯片型号功能只使用于部分25系列SPI FLASH芯片，24和93系列芯片无法进行自动识别，需要用户手工选择正确的型号。

2. 部分厂家的25系列SPI FLASH芯片识别命令比较特殊或无识别命令，这些厂家的芯片无法识别成功。

3. 同一厂家的多个相互兼容的芯片ID号可能相同，自动识别命令无法区分这些芯片，但不影响后续的读写操作。

如果出现上面的错误提示，可能的原因有:

1. 芯片未放好或损坏。

2. 芯片不是25系列SPI FLASH芯片。

3. 该芯片没有识别命令或识别命令特殊。


打开文件

打开文件

将文件中的数据加载到缓冲区。

支持的文件格式有*.bin和*.hex格式。

如果文件的长度大于当前所选择芯片的容量，那么超出部分将被丢弃！


保存文件

保存文件

将缓冲区中的数据保存到文件中。

支持的文件格式是二进制文件格式。


固件升级

固件升级

点“升级”按钮后，弹出选择文件对话框，从中选择正确的升级文件(*.ezp)后，等待几秒即可完成固件升级！

升级成功后弹出以下提示框:

如果升级失败，则会弹出以下对话框:

这时请从电脑上拔下编程器，点“确定”按钮，然后在10秒内将编程器连接到电脑。

如果这样操作仍然无法成功升级，请和经销商联系！


脱机拷贝

脱机拷贝

如上图中所示，将数据源芯片和待烧写芯片都放到编程器上时，编程器会自动启动脱机拷贝操作，完成芯片的拷贝功能。

有下面几点需要注意:

1. 使用脱机拷贝时，可以将编程器连接到电脑，也可以将编程器连接到其他5V稳压电源。

2. 支持从24系列芯片复制到24系列芯片。

3. 支持从25系列芯片复制到25系列芯片。

4. 数据源芯片的容量要等于待烧写芯片的容量。

5. 数据源芯片放在锁紧座下方的位置，待烧写芯片放在锁紧座上方的位置。


擦除芯片

擦除芯片

25系列SPI FLASH芯片写入数据前必须先执行擦除操作。

24、93系列芯片写入数据前不需要执行擦除操作。
25系列SPI FLASH芯片的擦除所花的时间因芯片而异，请耐心等待。


读芯片

读芯片

将芯片内的数据读到缓冲区中。


写芯片

写芯片

将缓冲区中的数据写如到芯片。


校验芯片

校验芯片

比较芯片和缓冲区中的数据是否相同。

在写芯片操作之后，校验芯片操作是必须的，可以保证写入数据的正确性！


自动完成

自动完成

本操作是一个组合操作，自动完成“擦除”、“写芯片”、“校验”操作。


常见问题解答

常见问题解答

1. 向芯片写入数据后，校验不通过。

(1)写数据前要选择正确的芯片型号。

(2)如果是25系列FLASH芯片，写入数据前一定要先擦除。

(3)如果是93系列芯片，存储器单元有8bit和16bit之分，写数据前要确认实际芯片的存储单元宽度是否和所选芯片的存储单元宽度一致。

(4)存储芯片可能已经损坏。

2. 读写芯片时芯片放的位置。

(1)如果是连接电脑读写芯片，芯片放在下图中的位置，芯片1脚靠近锁紧座扳手。

(2)如果是脱机拷贝，数据源芯片放在锁紧座下方的位置，待烧写芯片放在锁紧座上方的位置。

3. 自动检测芯片型号不正确。

请查看“自动检测芯片型号”一节！

4. 简易贴片转接座的使用。

简易贴片转接座上有两个焊接贴片芯片的位置，是并联的关系，使用时，可以任选一个位置使用，但不要同时焊接芯片。

该贴片转接座适用于焊接24、25、93系列宽体和窄体贴片器件。

5. 连接到主板在线刷BIOS芯片。

如果主板上的25系列BIOS芯片不便于取下来放到编程器读写，则可以将编程器直接连接到主板进行读写操作。

用户需要自制连接线，可以从转接座上将GND、CS、MISO、MOSI、CLK几根信号线引出并连接到主板。

需要主要的是，采用这种方式刷写BIOS芯片，需要主板的支持，否则可能会损坏编程器或主板。


版权声明

版权声明

EZP2010高速编程器软件及本用户手册版权归米克电子所有。

产品的发行和销售由购买者在许可协议条款下使用。

未经上海米克电子允许，任何单位及个人不得将该产品全部或部分复制、照相、再生、翻译或还原成其它机器可读形式的电子媒介。

本手册若有任何改动恕不另行通知。

因软件版本升级而造成的与本手册内容不符，请以软件为准。